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Pump-Fan-Compressor Sizing 

Introduction 
This program determines the fluid transportation characteristics of dominant 
pipeline process systems containing no loops.  In addition, it determines the 
yearly operating costs and the operating point based on equipment performance 
data.  A system curve is determined based upon pipe or duct pressure losses, 
fitting, and equipment pressure losses, and pressure losses (or gains) due 
changes in elevation on the discharge and suction sides of the pump or 
compressor. The system curve is plotted with the pump/compressor performance 
curve and the intersection gives the operating point.  Differential pressure 
requirements, Hydraulic HP (watts), and NPSH available (pumps) are calculated 
based on the Bernoulli equation.  By linking to Pipeline/Ductwork Sizing, Heat 
Exchanger Sizing, Flow Meter Sizing, and Control Valve Sizing modules, the 
corresponding frictional pressure drops can be imported into the 
Pump/Fan/Compressor Sizing module.  The performance curves of the popular 
models of several ANSI pump manufacturers are provided with the program.  
Alternatively, the users may use their own pump performance data. 

Energy is required to transport fluids from one location to another.  This energy 
is required to overcome equipment/vessel pressures, gravity, and friction.  
Gravity and pressure can either be contributors or dissipaters of energy based on 
whether the fluid is flowing against or with these forces.  Friction losses occur 
from contact of the fluid with the pipe walls or restrictions in the pipelines 
(equipment, control valves, flow meters, dampers, filters etc.). The suction and 
discharge differential pressures are determined by summing up the pressure 
changes due to the effects of friction and gravity in the suction and discharge 
segments, respectively.  The system differential pressure is the difference 
between the discharge and suction differential pressures.  This system 
differential pressure and the desired flow rate flow rate are used to select the 
pump/fan/compressor required for the service.  Affinity Laws determine system 
head at various flow rates, impeller diameters, and speeds (head is proportional 
to the square of the flow rate; flow rate, speed, and head are directly 
proportional; and equipment energy is proportional to the cube of the flowrate). 
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Window Description 

System Data Window  

 
 Pump Screen in the System Data Entry Mode 

Flow Rate and Fluid Properties 
Enter the design flow rate based on the type of flow (Liquid/Gas, 
Mass/Volumetric Flow) chosen in the Options menu.  The fluid properties will 
already have been posted to the respective fields if they had been determined in 
the Properties window accessible from the SmartDraw screen.  Alternatively, 
the user may either import a previously saved file, by clicking on the Properties 
button, or enter the required property data manually. 

System Elevations 
The elevation of the entrance of flow into the system (source elevation) and the 
point of exit of flow from the system (discharge elevation) need to be entered 
next (pump elevation is the datum or reference).  The source elevation is the 
elevation of the lowest point on the suction side while the discharge elevation is 
defined as the highest operating elevation on the discharge side of the pump.  If  
the pipeline elevation rises significantly above the highest discharge elevation, 
start-up problems may occur if additional head pressure is not added. 

System Pressures 
The source pressure is defined as the lowest operating pressure at the system 
source and the discharge pressure is defined as the highest operating pressure at 
the system discharge (the worst case from a pressure drop standpoint). 
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Pipe/Duct Pressure Drops 
The pipe/duct total pressure drop for the source and discharge sections are 
entered next.  By linking with the Pipeline/Ductwork Sizing program, these 
values may be imported into the respective fields.  The imported values are 
added to any value already entered in the input field.  Alternatively, these values 
can be determined separately and then added and entered in these fields.  

Equipment Pressure Drops 
Three columns are provided for the addition of various types of process 
equipment that affect the system differential pressure.  Enter the item 
description and its pressure drop in the respective fields.  Alternatively, the 
equipment pressure drops may be retrieved by importing the equipment file 
using the Import menu.  Open any previously saved equipment file for the type 
selected in the import menu, and the description and pressure drop will then be 
displayed in the appropriate input field.  Entering a negative equipment pressure 
drop will assign this value to the source side of the system.  This is reflected in 
the printouts as well. 

Performance Data Window 

 
Pump Screen in the Performance Data Entry mode 

Flow, Friction/Static Head, and Hydraulic HP 
This data will be pasted over from the System Data Entry window if calculated 
in that window.  The total system head consists of the friction head (pipe losses) 
and static head (elevation and pressure).  Only the friction head will vary with 
the flow rate (static head is constant).  The Hydraulic HP (kW) is adjusted to the 
operating flow and then divided by the energy required (HP or kW) to 
determine the pump/fan/compressor percent efficiency. 
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Impeller Diameter and Speed 
This allows for the adjustment of the entered performance data.  If the first value 
matches the adjusted value (or the adjusted value is zero) no adjustment to the 
performance data is made. Otherwise, the equipment heads/pressures, energy 
requirements, and performance curve will be adjusted along with the operating 
points based on the Affinity Laws.  Significant changes to manufacturer's data 
should not be made without consultation.  The Type menu for pumps allows the 
user to select impeller diameter or speed as the variable. 

Hourly Operation and Energy Costs 
Enter the approximate hourly operation per year and the local electrical energy 
costs to determine equipment operating costs.  The unit electrical costs from the 
Project Financial Analysis program (Project Management) will be shown 
initially. 

Manufacturer, Type, and Model Number 
These items will appear on the System Performance curve and printouts.  When 
loading a manufacturer's data set, they will automatically be shown when 
scrolling through the data using the View menu.  The total number of curves in 
the data set and the current curve will be shown at the top of the window.  Pump 
curves can be based on speed or impeller diameter as the performance variable.  

Flow rate, Head, and Energy Required 
This allows for entry and/or modification of manufacturer's equipment data.  
The system head is determined using the Affinity Laws (head ∝ flow^2, etc.).  
There should be an intersection of the system curve and the operating curve to 
establish an operating point.  When the impeller diameter or speed is adjusted 
and the calculation is performed, the equipment head/pressure data and power 
requirements will be updated. 
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System Performance Curve Window  

 
The System and Performance Curves 

Once an acceptable operating point is established, the System Performance 
Curve option can be selected from the Mode menu to graphically detail the 
operating conditions as shown.  If an adjusted value was entered for the impeller 
diameter or speed, the curve will reflect the adjusted performance and operation. 
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Menu Description 

File Menu  

 
The first section of this menu offers the choices of starting a new analysis, 
opening and saving calculations, getting manufacturers' equipment performance 
data (available in the Performance Data Entry mode only), printing out the 
results, and viewing the help screens. The Change Units option switches 
between English and Metric units.  In the second section, Copy and Paste, are 
used to copy/paste data to/from the Conversion Calculator and other input 
fields. 

Options Menu   

 
This pull down menu offers the choice of selecting either a pump, fan, or 
compressor and the flow rate units (either volumetric or mass flow). 

Mode Menu   

 
This menu is used to access the different windows in the program.  The System 
Data Entry window is used for determining the design conditions of a process 
system.  The Performance Data Entry window is used to input equipment 
performance data and determine system pressures at various conditions.  The 
System Performance Curve can then be plotted with the final option (only if 
data entry has been completed and values calculated). 
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Import Menu   

 
This pull-down menu offers links to the other equipment sizing programs from 
where the pressure drops may be imported to determine the fluid transportation 
requirements of a single line process system.  Choose the desired program to 
import the pressure drop form, select the previously saved file and click OK.  
The corresponding pressure drop field will automatically be filled up.  The user 
may enter the pressure drop information directly if it is already known. 

Stages Menu   
For Compressors, this adjusts the power requirements accordingly. 

View Menu   

 
This allows quick access to different models within a manufacturer's equipment 
data set (data entry sheet and file format are shown at the end of this section). 
First select the data file using the Get Data option in the File menu (Data Entry 
mode only) which will show the current model number and total models 
available.  Selection of the Data Intersection option will go to the first curve 
which meets the system flow and head requirements.  When only one curve is 
available for a given model, the maximum diameter or speed is displayed. 

Type Menu   

 
This menu allows the user to select the variable (Performance Data Entry 
Mode). 
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Calculation Basis 
The Bernoulli equation and the Affinity Laws form the basis of this design.  The 
differential pressure requirements, hydraulic horsepower and NPSH are 
calculated using the Bernoulli equation and is used to specify the 
pump/fan/compressor required for the service.  The Affinity Laws are used to 
determine the system and performance data at different flow rates, speeds and 
impeller diameter.   

Assumptions 
1. Liquids are assumed to be incompressible and “Newtonian”. 

2. Gases are assumed to be ideal. 

Limitations 
1. Fluid transportation requirements are determined for simple, non-

looped systems. 

2. Results displayed are for centrifugal pumps, fans and compressors. 
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Pump 
 NPSH = H

S
 - H

VAP
 + H

ATM
 

EQPIPEL
1

S HHH144PH −−+=
ρ  

EQPIPEL
2

D HHH144PH +++=
ρ  

ρ
144PHHH DSTOT =+=

 

3600550
WHHP TOT

PUMP ×
=

 

Compressor 

⎥
⎥
⎥

⎦

⎤

⎢
⎢
⎢

⎣

⎡
−⎟⎟

⎠

⎞
⎜⎜
⎝

⎛
⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
=

−

1
P
PRT

1-
H

1

1

2
AD

γ
γ

γ
γ

 

3600550
WH=HP AD

COMP ×    



 
E n g i n e e r ’ s  A i d e  R e f e r e n c e  G u i d e  

 
 

 
Engineer’s Aide Reference Guide  © 2007 EPCON International Pump-Fan-Compressor Sizing • 9 

Fan 
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Nomenclature 
H  head, ft. water (60 F) 

HP  power, hp 

NPSH  net positive suction head available, ft. water (60 F) 

P  pressure, psig 

Q  volumetric flowrate, cu.ft./hr 

R  gas constant, (=1545.0) ft.-lb/lbmol/R 

T  temperature, R 

W  mass flowrate, lb/hr. 

γ  ratio of specific heats (C
p
/C

v
) 

ρ  density of water (60 F), lb/cu. ft. 

Subscripts 
1  suction 

2  discharge 

AD  adiabatic 

ATM  atmospheric pressure 

COMP  compressor 

D  total discharge 

EL  elevation 

EQ  equipment losses 

FAN  fan 

PIP  pipe losses 

PUMP  pump 

S  total suction 

TOT  total system 

VAP  vapor pressure 

 Recommendations 
1. The flow rate and the suction and discharge pressures must be 

based on the temperature of the fluid being pumped. 

2. If system requirements for reciprocating pumps are being 
determined, allowance must be made for the NPSH available due 
to the acceleration head.  
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3. Modification to manufacturers’ data is not recommended without 
their consultation. 
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Example Problem 

Example 1 
A hot process water spray system needs a pump to meet the process 
requirements: 535 GPM (121.5 m3/hr) of heating water from 150oF to 180oF 
(65.6oC - 82.2oC) and then sprayed in a 7.5 PSIG (51.7 KPA) pressure vessel.  
The source and discharge elevations are 2 ft and 25 ft. respectively.  for source 
and discharge pipe losses and pressure drop due to other equipment are shown 
in the figure on the next page. 

Step by Step Solution Procedure 
1. Enter the Thermophysical Properties window from the SmartDraw 

screen or the CHEMPRO Home Page.  Type in a temperature of 
150oF.  Select water from the drop down list at the bottom of the 
screen  Click the Calculate Properties button and then click OK to 
exit the window after the properties are displayed. 

2. Click on the Pump/Fan/Compressor Sizing button from the 
CHEMPRO Home Page or  the SmartDraw screen .  Select Pump 
(volume flow) from the Option menu, and System data from the 
Mode menu.   

3. Key in the input data i.e. flow rate (535 gpm), the source pressure  
(0 psig) and discharge pressure(7.5 psig), the source elevation (2 
ft) and discharge elevation (25 ft). 

4. Key in the source and discharge pipe losses.  If the pipelines have 
already been sized (as in this case), the pressure loss in the source 
and discharge segments would be known and may be entered 
directly.  If the pipelines have not been sized, they can be sized 
and the pressure drops obtained by linking to the 
Pipeline/Ductwork sizing program.  To do this, select 
Pipeline/Ductwork Sizing from the Import menu.  Select 
Discharge Segment.  This will activate the Pipeline Sizing screen.  
After selecting the material, size and type of pipe from the menus, 
fill in the input values, retrieve fluid properties and then click on 
calculate to obtain the pressure drop in the discharge segment.  
From the File menu click on Exit to return to the pump screen.  
The field for the pressure loss in the discharge segment would 
have been filled in.  To obtain the source pipe pressure loss, select 
Source Segment from the Pipeline/Ductwork Sizing option on the 
Import menu.  Repeat the above procedure to obtain the pressure 
drop.  For this example, directly type in the pressure drops for the 
source and discharge piping as shown in the figure. 

5. Pressure losses through flow meters, control valves or other 
equipment if present on the line must be filled in.  The names may 
be entered as shown in the figure, and the pressure drop values 
filled in.  If the pressure losses in the control valve and flow 
meters are unknown, you may link with these programs to obtain 
the pressure drops through them.  For this example, directly type in 
the pressure drops for the source and discharge piping as shown in 
the figure. 
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6. The input is now complete.  Click on Calculate to obtain the 
results. 

 
System Data Screen of Pump for Example 1 

 
Performance Data Screen of Pump for Example 1 

7. To obtain the performance data, select the Performance Data 
Entry option from the Mode menu to activate the Performance 
Data screen.  The manufacturer’s data is displayed.  This data may 
be altered or a different manufacturer’s data may be obtained by 
selecting the Get Data option in the File menu.  The desired data 
file may be selected here.  From the View menu, select the Data 
Intersection option to obtain the pump that will fulfil the 
requirements.  You may also scroll up or down from the View 
menu to access the various pump data and specifications.  Click on 
Calculate to obtain the results. 

8. To view the system performance curve, select this option from the 
Mode menu. 


